Karttaselain tukee nyt Nokian S60 5th Edition puhelimiin automaattisesti päivittyvää Flash Lite 3.1 -versiota. Samalla poistui myös ylimääräinen varoitusdialogi yhteensopimattomuudesta S60 5th Edition alustan kanssa. Alla vielä lyhyt lista muutoksista versiossa 0.4.1:

– Tuki Flash Lite 3.1 -versiolle (lähinnä Nokia 5800)
– ”Puhelin ei ole tuettu” -varoitusviesti poistettu Nokia 5800 -mallista
– Kartan siirtoa nuolinäppäimistöllä nopeutettu